วันอาทิตย์ที่ 24 กุมภาพันธ์ พ.ศ. 2551

เย! ใช้ Compiz ได้แล้ว

เรื่องมันมีอยู่ว่า แล็ปท็อปที่ใช้อยู่ประจำนี้ ใช้ชิปกราฟิกของ ATI รุ่น Radeon Xpress 200M ซึ่งเดิมไม่สามารถใช้ compiz ได้เพราะไดรเวอร์ ไม่ว่าจะเป็นตัวที่เป็นโอเพนซอร์ส หรือ restricted ไม่สามารถใช้ AIGLX ได้ ต่อมาเมื่อ ATI ออกไดรเวอร์ใหม่ที่สนับสนุน AIGLX แล้ว แต่ผมกลับไม่สามารถรัน compiz ได้อยู่ดี ทีแรกเข้าใจว่าไดรเวอร์อาจจะไม่สมบูรณ์ โดยเฉพาะกับชิปรุ่นนี้ ซึ่งถือว่าเป็นรุ่นล่าง ๆ เลยทีเดียว เมื่อหาใน google พบว่ามีบางคนพบปัญหาแบบเดียวกัน error คล้าย ๆ กันโดยไม่รู้สาเหตุ แต่ที่น่าแปลกคือ เป็นส่วนน้อยมาก ๆ

วันนี้มานึก ๆ ทบทวนดูอีกที Ubuntu 7.10 ที่ใช้อยู่ทุกวันนี้ มันถูกอัพเกรดมาจากรุ่น 6.10 ซึ่งเป็นรุ่นที่ติดตั้งเป็นครั้งแรกสำหรับเครื่องนี้ จากนั้นไม่เคยติดตั้งใหม่เลย มีแต่ dist-upgrade มาตลอด เช่นจาก 6.10 มาเป็น 7.04 แล้วก็เป็น 7.10 โดยไม่เคยอัพเกรดใหญ่ผ่าน update-manager เลยสักครั้ง ซึ่งความต่างคือ การอัพเกรดด้วย aptitude dist-upgrade นั้นมีความเป็นไปได้ ที่จะติดตั้งแพกเกจสำคัญสำหรับรุ่นใหม่นั้นไม่ครบ ว่าแล้วก็ aptitude search compiz พบว่า เราติดตั้งไปเฉพาะ compiz-core ตัวเดียวเอง???

ลองติดตั้งส่วนอื่น ๆ เพิ่มสิ โดยสั่ง aptitude install compiz compiz-fusion-plugins-extra compiz-gnome compizconfig-settings-manager จากนั้นก็ลองรัน compiz --replace ดู อ้าวเฮ้ย ใช้ได้แล้ว

screenshot

แปลว่ามันคงทำได้ตั้งนานแล้วละสิ มันเพียงแต่ขาดแพกเกจบางตัวเท่านั้น ซึ่งอาจจะเกิดกับเคสของผู้ใช้บางคน (เช่นผม) เท่านั้นด้วย ซึ่งอาจเนื่องมาจากการอัพเกรดรุ่นแบบไม่สมบูรณ์เช่นกรณีนี้ สำหรับคนที่พึ่งติดตั้งใหม่ คงจะไม่เกิดครับ และถ้าใครจะอัพเกรดรุ่น แนะนำให้ใช้ update-manager ดีที่สุดครับ

2 ความคิดเห็น :

  1. อยากได้มั่ง ... จะมากับ TLE10 ปะครับ ลอล.

    ตอบลบ
  2. หน้าจอเท่ห์มาก

    ตอบลบ